Джейлбрейк iOS 8

В начале недели команда хакеров из Китая выпустила утилиту Pangu для непривязанного джейлбрейка iPhone и iPad под управлением iOS 7.1. Поначалу в сети появилась информация, что устройства на второй бета-версии iOS 8 также совместимы с этой разработкой, но на практике это не подтвердилось. Впрочем, не стоит думать, что в новой версии операционной системы уже исправлены уязвимости в системе безопасности. Известно, что хакеры из Китая используют для взлома давно известную уязвимость в просроченных корпоративных сертификатах, чем не могут воспользоваться взломщики других стран, опасаясь уголовной ответственности. Компания Apple не исправила эту проблему до сих пор, так что с помощью утилиты Pangu также можно взламывать устройства под управлением бета-версий iOS 8. Разумеется, если немного ее доработать.

Хакер BlackGeek, известный разработкой утилиты GeekSn0w, смог немного модифицировать Pangu и доказал возможность взлома «восьмерки». В подтверждение этому он показал фотографии устройства и процедуры джейлбрейка, а главное — пообещал доработать китайское приложение и добавить поддержку iOS 8. На практике это вряд ли будет полезно, поскольку большинство твиков не будут работать на устройствах в новейшей операционной системой. Однако есть крошечная вероятность, что Apple в очередной раз проигнорирует проблему просроченных корпоративных сертификатов и китайская утилита будет поддерживать iOS 8 после ее релиза.
Читать далее