Apple Watch

В бета-версии watchOS 4.3.1 появилось предупреждение о том, что в будущих версиях системы перестанут работать старые приложения, разработанные для watchOS 1.0.

При открытии приложений, которые давно не обновлялись разработчиком, watchOS 4.3.1 уведомляет пользователя, что такие программы в скором времени будут несовместимы с платформой. По данным AppleInsider, компания Apple предупредила об этом разработчиков приложений еще в прошлом году.

В первой бета-версии watchOS 4.3.1 старые программы все еще работают, если после появившегося предупреждения нажать кнопку «Ок». Можно предположить, что Apple откажется от поддержки таких приложений только в watchOS 5, анонс которой состоится на WWDC 2018.

В ноябре 2017 года Apple перестала публиковать в App Store программы, которые разработаны для watchOS 1 и не получили требуемых обновлений. С первого апреля разработчики должны использовать SDK для watchOS 2 или новее, чтобы компания разместила их приложения в магазине.



Канал iG в Telegram — t.me/iguides_ru